Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Ubuntu pre-required software added

...

Make sure you have the software LAMS needs! If you are unsure of what software is needed to run LAMS, go to the Development Environmentpage.

Installing all Pre-required Software

MySQL Database Server

See the Installing MySQL page. You can install MySQL on another server to the one running LAMS - the Unix/Linux installer will install LAMS on one server with MySQL running on another server.

...

Version:

4.0.2

Suggested Location

/usr/local/jboss-4.0.2

Source

www.jboss.org    http://labs.jboss.com/portal/jbossas/download

Comments

4.0.3SP1 and 4.0.4 have problems running LAMS, so 4.0.2 is your best bet until we fix the problem.

Installing all Pre-required Software in Ubuntu

We tent to use Ubuntu server and these are the quick steps we take to set up LAMS:

Ubuntu Feisty (7.04)

This will install Sun Java JDK 1.5, Ant and MySQL 5.0 Server

Code Block
titlePackages required for LAMS2
borderStylesolid

# apt-get install ant sun-java5-jdk  mysql-server-5.0

Now, let's get JBoss Appserver

Code Block
titleGet JBoss
borderStylesolid

cd /usr/local
wget http://superb-west.dl.sourceforge.net/sourceforge/jboss/jboss-4.0.2.tar.gz
tar xvzf  jboss-4.0.2.tar.gz

Wildfire Jabber server:

Code Block
titleGet JBoss
borderStylesolid

cd /usr/local
wget http://www.igniterealtime.org/builds/wildfire/wildfire_2_6_2.tar.gz
tar xvzf wildfire_2_6_2.tar.gz

See instructions on how to install WildFire

Downloading LAMS for Unix

Check that you have the latest LAMS 2 Unix installer

See the downloads page.

Anchor
mysql
mysql

...