Child pages
  • Installing Java

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Migrated to Confluence 4.0

LAMS require a full JAVA JDK environment to run, not just the JRE (runtime environment) that you might already have on your PC. LAMS is developed and tested with the Sun JAVA JDK - it may or may not run on Java platforms from other sources.

Sun JAVA JDK is available from the Sun Java site. You need to get the one that looks closest to:

Panel

JDK 6u1

The Java SE Development Kit (JDK) includes the Java Runtime Environment (JRE) and command-line development tools that are useful for developing applets and applications.

They update the version on a regular basis, and change the text, so the one you want might not be an exact match to the above text.This is about 60 MB.
This is about 50 MB. See the installation instructions.

Info

You can also use Java 1.5. However, Java 1.4.x won't work.

Warning: 64-bit Windows 2003 Servers

On the 64-bit Windows 2003 server when Java may install as c:/program files (x86)/Java/ ... This may stop LAMS starting. Try moving the directory to c:/program files/ and update your JAVA_HOME. Then LAMS should start.

Help!

Q: The recommended JDK is v6 or v5, but on some pages I see references to JDK 1.5. What do I get?
A: Version 5 and 1.5 are the same thing. The "numbers" for Java keep changing. You may also hear v6 referred to as 1.6.  Just get the one marked JDK 6<something>.

Q: Do I need to Download "JDK 6 with Java EE"? Isn't LAMS a J2EE application?
A: No you do not. The J2EE libs from JBOSS are sufficient for running (or compiling) LAMS.

Q: Someone has said that I need the Java SDK, and not the JDK.
A: They mean the JDK - it gets called SDK by some longer term Java programmers. What you need to avoid is having only the Java runtime (JRE).