Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Comment: Migration of unmigrated content due to installation of a new plugin

You've tried running the Windows installer and LAMS doesn't work.

Before posting to the Problems Installing LAMS forum on the LAMS Community, read this page and get whatever logs you can. Then post to the forum and we'll try to help you sort out the problem.

Table of Contents
minLevel1
maxLevel1
indent7px
stylenone

The LAMS Installer fails with an error

If the LAMS Installer comes up with an error and won't run all the way through the install process then re-run the installer and try to get the following details:

Screen error

Get a copy of the error on the screen. A screenshot fine - just make sure it isn't a huge 8M file!

Detailed log and installation.properties

If you get as far as the "Installing" screen, then click on the "Show Details" button. That will display an error log.


Then before you click "Next" on this screen, you need to do 2 things:

(1) Right mouse click on the detailed log and copy the details to the clipboard. Then go into notepad, paste the log into a file and save


(2) Go to your temp directory (e.g. c:\temp) and look for a file installer.properties. Copy the installer.properties somewhere else. You must copy it now, as it will be deleted when you click the next button.

Post to the LAMS Community

When you post to the forum, please tell us

  • Was MySQL installed via the MySQL installer, or via a package like xampp?
  • The version of MySQL. You can find this out by going to the command shell (do Start, Run), change to the directory where MySQL is and do "bin\mysql.exe -u<username> -p<password>". e.g.
    Code Block
    C:\Program Files\xampp\mysql>bin\mysql.exe -ulams2 -pxxxxxxxx
    Welcome to the MySQL monitor.  Commands end with ; or \g.
    Your MySQL connection id is 580
    Server version: 5.0.33 Source distribution
    
    Type 'help;' or '\h' for help. Type '\c' to clear the buffer.
    
  • The version of Java if you know it.
  • Put any screenshots, the detailed log and the installer.properties file in a zip file and attach it to the posting. You should open the installer.properties file in notepad and remove any sensitive information like passwords out of the file before putting it in the zip file.

The installer runs successfully but LAMS won't start up

If you can't get through to the LAMS login screen at all (for example, JBoss won't start up properly, JBoss will start but the log is full of errors, if you try to LAMS url it just gives Apache Tomcat error messages) then:

  1. Do the install again and get all the details from the previous section ("The LAMS Installer fails with an error") except for the installer error message. So get a copy of the detailed log, the installer.properties file, the MySQL and Java versions.
  2. Start LAMS in debug mode and get the log files listed on the Reporting Problems and Creating DEBUG Logs page.
  3. Get the error message that you get when you try to go to the LAMS url (e.g. http://localhost:8080/lams)
  4. Bundle up all the errors, files, etc into a zip file and attach them to your posting on the forum.

LAMS starts up but behaves oddly

So LAMS is installed, you can get to the login screen but something isn't right. Have a look at our general troubleshooting page and if that doesn't help, then report the problem to the forum after reading the Reporting Problems and Creating DEBUG Logs.